Eclipse 3.5M3 est disponible!

La milestone 3 de Galileo est sortie hier, et amène (comme d’habitude ?) plein de nouveautés très sympa, extraites du traditionnel “New & Noteworthy” :

Platform 

  • La sélection par bloc dans les éditeurs texte fait enfin son apparition (un bug était ouvert depuis… 2002 !), et c’est un grand soulagement pour tous les développeurs Cobol ! 😉
    Plus sérieusement, cette fonctionnalité peut faire gagner énormément de temps quand on a besoin de bidouiller des fichiers CSV, par exemple…

 

  • On peut désormais associer des icônes à des entrées de la table des matières

JDT

  • De même que l’on pouvait déjà coller le contenu d’une classe Java qu’on aurait copié dans son presse-papiers, on peut désormais directement appliquer un patch en le collant n’importe où dans son Package Explorer !

p2

  • L’IHM de p2 a été pas mal remaniée pour encore plus simplifier son utilisation. N’hésitez pas à faire des retours sur cette page du wiki Eclipse.

PDE

  • Le PDE/Build supporte désormais la compilation “multicore” introduite dans JDT avec Ganymede. Ainsi, PDE Build va détecter les grappes de plug-ins complétement indépendantes, et les compiler en parallèle.
    Allez donc jeter un oeil ici pour plus de détails sur la façon (ultra-simple !) d’activer cette fonctionnalité dans vos builds.
  • L’éditeur graphique de Declarative Services OSGi est encore et toujours amélioré (pour rappel, c’est un des principaux chantiers du PDE pour cette version 3.5)

 

  • Dans les assistants d’export de plug-ins et de features, on peut demander à directement installer les fonctionnalités exportées… dans son environnement de développement !
    C’est une fonctionnalité très intéressante, mais qui n’a malheureusement qu’un intérêt plus limité quand on n’est pas développeur d’Eclipse-même… 😐
Pour le New&Noteworthy complet, c’est ici ; les téléchargements étant eux… là-bas ! 🙂

2 thoughts on “Eclipse 3.5M3 est disponible!”

  1. Oui bien sûr!
    Il faut utiliser l’agent p2 pour réaliser le provisioning : http://download.eclipse.org/equinox/drops/S-3.5M3-200810301917/index.php#Provisioning

    Il faut créer un profil, en prenant bien soin de choisir deux endroits différents pour l’install folder (là où se trouvera le eclipse.exe, les dossiers configuration/ et dropins/ …) et pour le bundle pool.

    Mais attention, malheureusement l’update site http://download.eclipse.org/eclipse/updates/3.5milestones/ expose pour l’instant seulement la M1… 🙁 Il va falloir attendre la M4 (prévue le 12 si ma mémoire est bonne) pour que cette petite erreur soit réparée ..!
    En attendant, il est possible d’utiliser l’update site des versions d’intégration (http://download.eclipse.org/eclipse/updates/3.5-I-builds/) pour installer une “pré-M4” (mais les I-builds de ces derniers sont pas super stables… :))

Leave a Reply

Your email address will not be published. Required fields are marked *